VS:vsoGetEventInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 7: Line 7:
Returns the ID of the event in an event-enabled object. If the event was a button press, outEventData will indicate which button it was.
Returns the ID of the event in an event-enabled object. If the event was a button press, outEventData will indicate which button it was.


See the <a href=http://www.vectorlab.info/index.php?title=Events>VectorLab article</a> on object events.
</desc>
</desc>



Latest revision as of 15:10, 3 March 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the ID of the event in an event-enabled object. If the event was a button press, outEventData will indicate which button it was.

PROCEDURE vsoGetEventInfo(
VAR outObjEvent :LONGINT;
VAR outEventData :LONGINT);
def vs.vsoGetEventInfo():
    return (outObjEvent, outEventData)

Parameters

outObjEvent LONGINT Output parameter.
outEventData LONGINT Output parameter.

Version

Availability: from All Versions

This is drop-in function.