VS:vsoAddParamWidget: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 24: Line 24:
widgetID
widgetID
LONGINT
LONGINT
 
A unique number specified by the user to identify this widget.
</line>
</line>
<line>
<line>
paramName
paramName
STRING
STRING
 
The universal name of the parameter.
</line>
</line>
<line>
<line>
locName
locName
STRING
STRING
 
Localized text that will appear next to the widget. <b>Note!</b> If you specify an empty string, the alternate name of the parameter will be used.
</line>
</line>
</lineList>
</lineList>

Revision as of 18:41, 20 March 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Add a widget for parameter to appear in the Object Info Palette.

FUNCTION vsoAddParamWidget(
widgetID :LONGINT;
paramName :STRING;
locName :STRING) : BOOLEAN;
def vs.vsoAddParamWidget(widgetID, paramName, locName):
    return BOOLEAN

Parameters

widgetID LONGINT A unique number specified by the user to identify this widget.
paramName STRING The universal name of the parameter.
locName STRING Localized text that will appear next to the widget. Note! If you specify an empty string, the alternate name of the parameter will be used.

Version

Availability: from Vectorworks 2011