VS:YCenter

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012. See YCenterN for a replacement function.


Returns the y-coordinate of the center point of an object matching the serach criteria. If more than one object matches the search criteria, the function will return the sum of the coordinates of all the matching objects.

FUNCTION YCenter(
c :CRITERIA) : REAL;
def vs.YCenter(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Example

VectorScript

YCenValue:=YCenter(N='Board');
{returns the y-coord of the center of the named object 'Board'}

Python


Version

Availability: from All Versions

Deprecated: Vectorworks 2012