VS:YCenter

From Vectorworks Developer
Revision as of 14:50, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012. See YCenterN for a replacement function.


Returns the y-coordinate of the center point of an object matching the serach criteria. If more than one object matches the search criteria, the function will return the sum of the coordinates of all the matching objects.

FUNCTION YCenter(
c :CRITERIA) : REAL;
def vs.YCenter(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Example

VectorScript

YCenValue:=YCenter(N='Board');
{returns the y-coord of the center of the named object 'Board'}

Python


Version

Availability: from All Versions

Deprecated: Vectorworks 2012