VS:XCenter: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 14:50, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012DEPRECATED after Vectorworks2012. See XCenterN for a replacement function.


Returns the x-coordinate of the center point of an object matching the serach criteria. If more than one object matches the search criteria, the function will return the sum of the coordinates of all the matching objects.

FUNCTION XCenter(
c :CRITERIA) : REAL;
def vs.XCenter(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Example

VectorScript

XCenValue:=XCenter(N='Board');
{returns the x-coord of the center of the named object 'Board'}

Python


Version

Availability: from All Versions

Deprecated: Vectorworks 2012