VS:WriteMac

From Vectorworks Developer
Revision as of 14:50, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Outputs the specified data to an ASCII text file. The variable length parameter list specifies the data to be written to the file.

Parameters may be any valid data type, and data types may be mixed in a single call to the procedure. WriteMac leaves the file pointer positioned at the end of the last data value written to the file; any data subsequently written to the file will be appended to the end of this value.

See the VectorScript Language Guide for details on formatting values using WriteLn.

PROCEDURE WriteMac(
z :ANY);
def vs.WriteMac(z):
    return None

Parameters

z ANY

Example

VectorScript

WriteMac(Value1);

Python


Version

Availability: from VectorWorks9.0