VS:WriteBin

From Vectorworks Developer
Revision as of 10:00, 25 December 2017 by CBM-c- (talk | contribs) (wikify)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure WriteBin outputs the specified data to a binary file. The variable length parameter list specifies the data to be written to the file.

Supported data types include INTEGER (2-bytes), REAL (8-bytes), LONGINT (4-bytes), CHAR (1-byte) or STRING/DYNARRAY OF CHAR (see remarks).

The bytes will be written as little-endian.

Strings will require two additional INTEGER parameters: symbol count and encoding:

0 – mac
1 – win
2 – system
3 – UTF8
4 – UTF16
PROCEDURE WriteBin(
z :ANY);
def vs.WriteBin(z):
    return None

Parameters

z ANY

Example

WriteBin(Value1);

Version

Availability: from Vectorworks 2018

See Also

VS:ReadBin | VS:Open

[[VS:ReadBin]] | [[VS:Open]]