VS:WallWidth

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function WallWidth returns the wall width of the referenced wall object.

FUNCTION WallWidth(
wallHd :HANDLE) : REAL;
def vs.WallWidth(wallHd):
    return REAL

Parameters

wallHd HANDLE Handle to wall.

Remarks

"Function WallWidth returns the wall width of the referenced wall object", whereas VS:HWallWidth changes the width of the referenced wall. GetWallThickness(wallHandle, thicknessDist)

(http://www.nemetschek.net/support/custom/vscript/reference/asp/main.asp?name=GetWallThickness) does the same as WallWidth, but is often more practical and at least looks better in scripts.

Version

Availability: from MiniCAD6.0

See Also

VS Functions:

VS:GetWallThickness | VS:HWallWidth

VS Functions:

[[VS:GetWallThickness]]

| [[VS:HWallWidth]]