VS:WallTo/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

現在のペン位置から指定した座標まで壁を作成します。

PROCEDURE WallTo(
p :REAL);
def vs.WallTo(p):
    return None

Parameters

p REAL 壁の終点の座標

Example

PROCEDURE Example;
VAR
	x1, y1, x2, y2 :REAL;
	resourceID :LONGINT;
	wallStyleCnt :INTEGER;
	wallStyleName :STRING;
	wallStyleHand :HANDLE;
BEGIN
	resourceID := BuildResourceList(127, 113, '', wallStyleCnt);
	IF wallStyleCnt > 0 THEN BEGIN
		wallStyleName := GetNameFromResourceList(resourceID, 1);
		AlrtDialog(wallStyleName);
		wallStyleHand := ImportResourceToCurrentFile(resourceID, 1);
		SetWallPrefStyle(wallStyleName);
	END ELSE BEGIN
		SetWallWidth(3.5");
	END;
	GetPt(x1, y1);
	GetPtL(x1, y1, x2, y2);
	MoveTo(x1, y1);
	WallTo(x2, y2);
END;
RUN(Example);

Version

利用可能バージョン: MiniCAD4.0