VS:WallTo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure WallTo creates a wall object in a VectorWorks document. WallTo begins the wall at the current graphics pen position, with the end point at the specified location.

To explicitly set the start point of the wall, WallTo must be preceded by either Procedure MoveTo, LineTo, Wall, or WallTo. The procedure automatically performs a join/cleanup operation an intersection if the previous procedure was a wall creation procedure.

PROCEDURE WallTo(
pX,pY :REAL);
def vs.WallTo(p):
    return None

Parameters

p REAL End point of wall.

Example

VectorScript

PROCEDURE Example;
VAR
x1, y1, x2, y2 :REAL;
resourceID :LONGINT;
wallStyleCnt :INTEGER;
wallStyleName :STRING;
wallStyleHand :HANDLE;
BEGIN
resourceID := BuildResourceList(127, 113, '', wallStyleCnt);
IF wallStyleCnt > 0 THEN BEGIN
wallStyleName := GetNameFromResourceList(resourceID, 1);
AlrtDialog(wallStyleName);
wallStyleHand := ImportResourceToCurrentFile(resourceID, 1);
SetWallPrefStyle(wallStyleName);
END ELSE BEGIN
SetWallWidth(3.5");
END;
GetPt(x1, y1);
GetPtL(x1, y1, x2, y2);
MoveTo(x1, y1);
WallTo(x2, y2);
END;
RUN(Example);

Python


Version

Availability: from MiniCAD4.0