VS:WallPeak

From Vectorworks Developer
Revision as of 14:50, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a wall peak of the specified height at a specified distance from the wall start point.

There is no error checking of the distance or peak height parameters; it is left to the programmer to ensure that the parameter values are valid.

PROCEDURE WallPeak(
alongDistance :REAL;
heightDistance :REAL);
def vs.WallPeak(alongDistance, heightDistance):
    return None

Parameters

alongDistance REAL Location of peak (measured from wall start point).
heightDistance REAL Elevation of wall peak.

Example

VectorScript

SetZVal(0',8');
Wall(0,0,7,0);
WallPeak(3'-6",9'-0");
{creates a 9' wall peak 3'-6" from the start point of the wall}

Python


Version

Availability: from MiniCAD4.0