VS:WallFootPrint

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the handle of a polyline representing the footprint of a wall.

FUNCTION WallFootPrint(
wallHandle :HANDLE) : HANDLE;
def vs.WallFootPrint(wallHandle):
    return HANDLE

Parameters

wallHandle HANDLE Handle to the wall

Return Value

Returns the handle of a polyline representing the footprint of a wall.

Remarks

_c_, (2008.01.07): This actually generates the footprint object in the parent container (active layer or whatever other parent). It doesn't only return a handle.

_c_, (2011.01.30): You might need to regen it using ResetObject in order to actually see/use it in the drawing. Mind that this object is always a screen plane polyline, unregarded the active plane, and that its vertexes are all hidden.

Example

VectorScript

PROCEDURE GetWallFootPrint;
VAR
h1, h2 :HANDLE;
BEGIN
h1 := FSActLayer;
h2 := WallFootPrint(h1);
END;
RUN(GetWallFootPrint);

Python


Version

Availability: from VectorWorks 10.0