VS:WSScript GetObject: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(add link to the TechBoard: Pats's intro to WS scripting)
Line 24: Line 24:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>[[User:CBM-c-| _c_]] (2021.02.08):
See excellent intrduction to Worksheet Scripting by Pat Stanford on the Techboard:
forum.vectorworks.net/index.php?/topic/75193-a-super-short-course-in-worksheet-scripts/
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 03:07, 8 February 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function must be used inside a worksheet script called by 'RunScript' worksheet formula.

FUNCTION WSScript_GetObject : HANDLE;
def vs.WSScript_GetObject():
    return HANDLE

Return Value

Returns the object currently being processed by the worksheet criteria at the time of the script execution.

Remarks

_c_ (2021.02.08):

See excellent intrduction to Worksheet Scripting by Pat Stanford on the Techboard: forum.vectorworks.net/index.php?/topic/75193-a-super-short-course-in-worksheet-scripts/

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:WSScript_GetObject | VS:WSScript_GetPrmInt | VS:WSScript_GetPrmReal | VS:WSScript_GetPrmStr | VS:WSScript_SetResStr | VS:WSScript_SetResReal | VS:WSScript_SetResImage

VS Functions:

[[VS:WSScript_GetObject]] | [[VS:WSScript_GetPrmInt]] | [[VS:WSScript_GetPrmReal]] | [[VS:WSScript_GetPrmStr]] | [[VS:WSScript_SetResStr]] | [[VS:WSScript_SetResReal]]

| [[VS:WSScript_SetResImage]]