VS:WSScript GetEditObj: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:48, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function must be used inside a worksheet script called by 'RunScriptEdit' worksheet formula. It will return the object being edited when 'WSScript_GetEdit' returns that the script is in edit mode.

FUNCTION WSScript_GetEditObj(
objIndex :INTEGER;
VAR outObj :HANDLE) : BOOLEAN;
def vs.WSScript_GetEditObj(objIndex):
    return (BOOLEAN, outObj)

Parameters

objIndex INTEGER Index to the object to be returned as the script can be called for a set of objects. Will return FALSE if no such object.
outObj HANDLE Output the object that is being edited.

Return Value

Return FALSE and NIL or vs.Handle() if the index is outside the range.

Version

Availability: from Vectorworks 2021

See Also

VS Functions:

VS:WSScript_GetEdit

VS Functions: [[VS:WSScript_GetEdit]]