VS:WSScript GetEdit

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function must be used inside a worksheet script called by 'RunScriptEdit' worksheet formula. It will tell the script when a value has been change and what's the value. Use 'WSScript_GetEditObj' to get the value.

FUNCTION WSScript_GetEdit(
VAR outNewValue :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.WSScript_GetEdit():
    return (BOOLEAN, outNewValue)

Parameters

outNewValue DYNARRAY[] of CHAR The new value for the cell as inputted by the user.

Return Value

Return true if the cell is being edited.

Version

Availability: from Vectorworks 2021

See Also

VS Functions:

VS:WSScript_GetEditObj

VS Functions: [[VS:WSScript_GetEditObj]]