VS:WSScript GetEdit: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:48, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function must be used inside a worksheet script called by 'RunScriptEdit' worksheet formula. It will tell the script when a value has been change and what's the value. Use 'WSScript_GetEditObj' to get the value.

FUNCTION WSScript_GetEdit(
VAR outNewValue :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.WSScript_GetEdit():
    return (BOOLEAN, outNewValue)

Parameters

outNewValue DYNARRAY[] of CHAR The new value for the cell as inputted by the user.

Return Value

Return true if the cell is being edited.

Version

Availability: from Vectorworks 2021

See Also

VS Functions:

VS:WSScript_GetEditObj

VS Functions: [[VS:WSScript_GetEditObj]]