VS:VsoStateMaterialChng

From Vectorworks Developer
Revision as of 19:18, 7 December 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ObjectState event is sent to Parametric objects when Material is changed.

FUNCTION VsoStateMaterialChng(
hObj :HANDLE;
VAR materialID :INTEGER;
VAR deleted :BOOLEAN;
VAR previousTexture :INTEGER) : BOOLEAN;
def vs.VsoStateMaterialChng(hObj):
    return (BOOLEAN, materialID, deleted, previousTexture)

Parameters

hObj HANDLE
materialID INTEGER
deleted BOOLEAN
previousTexture INTEGER

Version

Availability: from Vectorworks 2020