VS:Volume

From Vectorworks Developer
Revision as of 14:39, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the volume of the items matching the specified criteria. If more than one object matches the search criteria, the sum of all the volumes of the matching objects will be returned.

Volume will return only return volumes on objects which support the solids modelling functions.

FUNCTION Volume(
c :CRITERIA) : REAL;
def vs.Volume(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Remarks

This function returns the volume of the items matching the current criteria. It will return 0 for any objects that will not work with the solids modeling functions.

Example

VectorScript

totalVol:=Volume((C='Empty Space'));

Python


Version

Volume is obsolete as of VectorWorks12.5


Availability: from VectorWorks8.0