VS:VerifyLibraryRoutine

From Vectorworks Developer
Revision as of 22:21, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Verifies that a procedure or function call located in a VectorScript extension is registered and available for use in scripts.

Call this function prior to using any call located in a VectorScript extension to ensure successful use of the call in a script.

(A VectorScript extension is also known as an SDK Plug-in Library. It is a plug-in that is developed using the VectorWorks SDK and the C++ language. When installed in the Plug-ins folder it provides functions that may be called from VectorScript. The VerifyLibraryRoutine function allows the script to determine if the function is available.)

FUNCTION VerifyLibraryRoutine(
routineName :STRING) : BOOLEAN;
def vs.VerifyLibraryRoutine(routineName):
    return BOOLEAN

Parameters

routineName STRING Name of function call to be verified.

Return Value

Returns TRUE if the call is available, otherwise returns FALSE.

Version

Availability: from VectorWorks9.0