VS:VerifyLayout

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Checks a specified dialog layout for correct layout definition.

FUNCTION VerifyLayout(
dialogID :LONGINT) : BOOLEAN;
def vs.VerifyLayout(dialogID):
    return BOOLEAN

Parameters

dialogID LONGINT The index of the dialog layout to be verified.

Return Value

Returns FALSE if a problem was encountered defining the dialog, otherwise returns TRUE.

Remarks

[DWD 1/20/00]

Example

VectorScript

{verify the dialog layou is properly constructed}
dialogOK := VerifyLayout(lEditID);

IF (dialogOK & rsAvailable) THEN
BEGIN
lmtestResult := RunLayoutDialog(lEditID,DriveSplashDialog);
END;

Python


Version

Availability: from VectorWorks9.0