VS:ValidAngStr

From Vectorworks Developer
Revision as of 22:21, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function ValidAngStr returns TRUE if the specified value can be converted into a numeric angle value. If TRUE, the value (in decimal degrees) of the string is returned.

FUNCTION ValidAngStr(
str :STRING;
VAR value :REAL) : BOOLEAN;
def vs.ValidAngStr(str):
    return (BOOLEAN, value)

Parameters

str STRING String value to be checked for angle validity.
value REAL Returns numeric angle value converted from input string.

Return Value

Returns TRUE if the specified string can be converted into a angle value.

Example

VectorScript

PROCEDURE Example;
VAR
str :STRING;
value :REAL;
BEGIN
str := StrDialog('Enter the angle:', 'N10E');
IF ValidAngStr(str, value) THEN Message(value);
END;
RUN(Example);

Python


Version

Availability: from All Versions