VS:UpdateThumbnailPreview

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

For a given VectorWorks resource (i.e. Hatch, Texture, Symbol/PIO, etc...), this function will create or update it?s thumbnail preview.

FUNCTION UpdateThumbnailPreview(
resourceHandle :HANDLE) : BOOLEAN;
def vs.UpdateThumbnailPreview(resourceHandle):
    return BOOLEAN

Parameters

resourceHandle HANDLE Handle to the resource.

Return Value

This function returns true if the operation was successful, false otherwise.

Version

Availability: from VectorWorks11.0