VS:UpdateImageControl2

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Updates the image control created with CreateImageControl2

PROCEDURE UpdateImageControl2(
dialogID :LONGINT;
controlID :LONGINT;
imageSpecifier :DYNARRAY[] of CHAR);
def vs.UpdateImageControl2(dialogID, controlID, imageSpecifier):
    return None

Parameters

dialogID LONGINT The dialog identifier given by the command to create the dialog.
controlID LONGINT The identifier of the control to be updated.
imageSpecifier DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".

Version

Availability: from Vectorworks 2012