VS:TextFace

From Vectorworks Developer
Revision as of 22:16, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure TextFace sets the active text style of a VectorWorks document.

The text style may be one or a combination of the available styles, and should be enclosed in brackets. To specify multiple styles, each style should be separated by a comma.

PROCEDURE TextFace(
s :TEXTSTYLE);
def vs.TextFace(s):
    return None

Parameters

s TEXTSTYLE Style setting for document.

Remarks

Make sure the docs indicate that the face must appear in set notation - check it out [PCP]

Example

VectorScript

TextFace([Italic]);
{set the active text style to Italic}

TextFace([Bold,Outline]);
{set the active text style to bold outline}

Python


Version

Availability: from All Versions