VS:SurfaceArea: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
<b>See [[VS:SurfaceAreaN|SurfaceAreaN]] for a replacement function</b>
Returns the surface area of the items matching the specified criteria. If more than one object matches the search criteria, the sum of all the surface areas of the matching objects will be returned.
Returns the surface area of the items matching the specified criteria. If more than one object matches the search criteria, the sum of all the surface areas of the matching objects will be returned.



Latest revision as of 20:35, 11 November 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

See SurfaceAreaN for a replacement function

Returns the surface area of the items matching the specified criteria. If more than one object matches the search criteria, the sum of all the surface areas of the matching objects will be returned.

SurfaceArea will return only return areas on objects which support the solids modelling functions.

FUNCTION SurfaceArea(
c :CRITERIA) : REAL;
def vs.SurfaceArea(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Remarks

This function returns the volume of the items matching the current criteria. It will return 0 for any objects that will not work with the solids modeling functions.

Example

VectorScript

totalArea:=SurfaceArea((C='Empty Space'));

Python


Version

SurfaceArea is obsolete as of VectorWorks12.5


Availability: from VectorWorks8.0