VS:SubtractSolid: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(add comment)
Line 65: Line 65:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<remark>
[[User:Orso.b.schmid|Orso]], 2018.02.11:  obj1 = clipped, obj2 = clipper
Everything cuts the backmost object, which will be the 1st retrived using [[VS:FIn3D]].
A solid subtraction has object type 84 and subtype 516. Mind, also other objects have type 84, such as Generic Solids (eventually generated using [[VS:ExtrudeAlongPath]])
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 07:10, 11 February 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function SubtractSolid creates a new solid subtraction object from the referenced source objects.

Table - Solids Operation Result Codes
Operation Result Result Code
Success 0
Null geometry error 1
Geometry error 2
Out of memory error 4
Bad group error 5
Invalid object type 6
Bad input 20
FUNCTION SubtractSolid(
obj1 :HANDLE;
obj2 :HANDLE;
VAR newSolid :HANDLE) : INTEGER;
def vs.SubtractSolid(obj1, obj2):
    return (INTEGER, newSolid)

Parameters

obj1 HANDLE Handle to source object for subtract operation.
obj2 HANDLE Handle to source object for subtract operation.
newSolid HANDLE Handle to resultant object from subtract operation.

Remarks

Orso, 2018.02.11: obj1 = clipped, obj2 = clipper

Everything cuts the backmost object, which will be the 1st retrived using VS:FIn3D.

A solid subtraction has object type 84 and subtype 516. Mind, also other objects have type 84, such as Generic Solids (eventually generated using VS:ExtrudeAlongPath)

Version

Availability: from MiniCAD 7.0