VS:SubString: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (improve readability of example)
Line 48: Line 48:
<sample>
<sample>
<code lang='vs'>
<code lang='vs'>
middleStr:=SubString('Left;Middle;Right',';',2);</code>
middleStr := SubString('Left;Middle;Right', ';', 2);</code>
</sample>
</sample>



Revision as of 02:31, 21 September 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function SubString splits the Text string using characters specified in the Delemiters and returns the token located at the Index position.

The first token is located at index 1.
If there is an error the function returns (empty string).
If index is less than 1 or grater than max number of tokens the function returns (empty string).

FUNCTION SubString(
text :DYNARRAY[] of CHAR;
delimiter :STRING;
index :INTEGER) : DYNARRAY[] of CHAR;
def vs.SubString(text, delimiter, index):
    return DYNARRAY[] of CHAR

Parameters

text DYNARRAY[] of CHAR
delimiter STRING
index INTEGER

Example

middleStr := SubString('Left;Middle;Right', ';', 2);

Version

Availability: from Vectorworks 2014