VS:StairSetConstType

From Vectorworks Developer
Revision as of 11:04, 8 December 2020 by SBender (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets construction type of stair - not recommended for use
1: Solid
2: Stringer underneath
3: Stringer outside
4: Concrete
5: CircularWithTangentialSteps /* Special type used by circular stairs only */
See SDKLib/Include/Interfaces/Vectorworks/Extension/IStairCWSupport.h for more details.
FUNCTION StairSetConstType(
stair :HANDLE;
ConstructionType :INTEGER) : BOOLEAN;
def vs.StairSetConstType(stair, ConstructionType):
    return BOOLEAN

Parameters

stair HANDLE
ConstructionType INTEGER

Version

Availability: from Vectorworks 2021