VS:StairSetConstType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
(One intermediate revision by one other user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Sets construction Type of stair - not recommended for use</desc>
<lineList ident=2>
<line>
Sets construction type of stair - not recommended for use
</line>
<line>
1: Solid
</line>
<line>
2: Stringer underneath
</line>
<line>
3: Stringer outside
</line>
<line>
4: Concrete
</line>
<line>
5: CircularWithTangentialSteps /* Special type used by circular stairs only */
</line>
<line>
See SDKLib/Include/Interfaces/Vectorworks/Extension/IStairCWSupport.h for more details.
</line>
 
</lineList>
 
 
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 53: Line 79:


[[Category:VS Function Reference|StairSetConstType]]
[[Category:VS Function Reference|StairSetConstType]]
[[Category:VS Function Reference:StairCWVectorscripts|StairSetConstType]]
[[Category:VS Function Reference:Objects - Architectural|StairSetConstType]]

Latest revision as of 11:04, 8 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets construction type of stair - not recommended for use
1: Solid
2: Stringer underneath
3: Stringer outside
4: Concrete
5: CircularWithTangentialSteps /* Special type used by circular stairs only */
See SDKLib/Include/Interfaces/Vectorworks/Extension/IStairCWSupport.h for more details.
FUNCTION StairSetConstType(
stair :HANDLE;
ConstructionType :INTEGER) : BOOLEAN;
def vs.StairSetConstType(stair, ConstructionType):
    return BOOLEAN

Parameters

stair HANDLE
ConstructionType INTEGER

Version

Availability: from Vectorworks 2021