VS:StairSetConfigType

From Vectorworks Developer
Revision as of 10:58, 8 December 2020 by SBender (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets Stair Configuration Type. Not recommended for use as stair might end up with inconsistent and contradictory parameters.

<desc>

StraightStair = 1 /* Numbers need to match strings in string files and need to be consistent for compatibility so do not change order and values of these constants */
StraightTwoRuns = 2
LSingleLanding = 3
USingleLanding = 4
UDoubleLandings = 5
LWinder = 6
UDoubleWinder = 7
USingleWinder = 8
CircularStair = 9
Unused1 /* Required for compatibility */
StraightThreeRuns = 11
LFixedAngleWinder = 12
UDoubleFixedAngleWinder = 13
USingleFixedAngleWinder = 14
ZSingleLanding = 15 /* not supported yet */
ZDoubleLandings = 16/* not supported yet */
DoubleUDoubleLandings = 17 /* O-Stair with two 180 degree landings */
OStairTripleLandings = 18 /* O-Stair with three 90 degree landings */
See SDKLib/Include/Interfaces/Vectorworks/Extension/IStairCWSupport.h for more details.
FUNCTION StairSetConfigType(
stair :HANDLE;
ConfigurationType :INTEGER) : BOOLEAN;
def vs.StairSetConfigType(stair, ConfigurationType):
    return BOOLEAN

Parameters

stair HANDLE
ConfigurationType INTEGER

Version

Availability: from Vectorworks 2021