VS:StairGetConfigType

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns Stair Configuration Type.
ErrorStandardConfiguration = -1, /* Returned by VCOM functions if some error occurs */
StraightStair = 1 /* Numbers need to match strings in string files and need to be consistent for compatibility so do not change order and values of these constants */
StraightTwoRuns = 2
LSingleLanding = 3
USingleLanding = 4
UDoubleLandings = 5
LWinder = 6
UDoubleWinder = 7
USingleWinder = 8
CircularStair = 9
Unused1 /* Required for compatibility */
StraightThreeRuns = 11
LFixedAngleWinder = 12
UDoubleFixedAngleWinder = 13
USingleFixedAngleWinder = 14
ZSingleLanding = 15 /* not supported yet */
ZDoubleLandings = 16/* not supported yet */
DoubleUDoubleLandings = 17 /* O-Stair with two 180 degree landings */
OStairTripleLandings = 18 /* O-Stair with three 90 degree landings */
See SDKLib/Include/Interfaces/Vectorworks/Extension/IStairCWSupport.h for more details.
FUNCTION StairGetConfigType(
stair :HANDLE) : INTEGER;
def vs.StairGetConfigType(stair):
    return INTEGER

Parameters

stair HANDLE

Version

Availability: from Vectorworks 2021