VS:StairGetConfigType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns Stair Configuration Type.</desc>
<lineList ident=2>
<line>
Returns Stair Configuration Type.
</line>
<line>
ErrorStandardConfiguration = -1, /* Returned by VCOM functions if some error occurs */
</line>
<line>
                StraightStair = 1 /* Numbers need to match strings in string files and need to be consistent for compatibility so do not change order and values of these constants */
</line>
<line>
                StraightTwoRuns = 2
</line>
<line>
                LSingleLanding = 3
</line>
<line>
                USingleLanding = 4
</line>
<line>
                UDoubleLandings = 5
</line>
<line>
                LWinder = 6
</line>
<line>
                UDoubleWinder = 7
</line>
<line>
                USingleWinder = 8
</line>
<line>
                CircularStair = 9
</line>
<line>
                Unused1 /* Required for compatibility */
</line>
<line>
                StraightThreeRuns = 11
</line>
<line>
                LFixedAngleWinder = 12
</line>
<line>
                UDoubleFixedAngleWinder = 13
</line>
<line>
                USingleFixedAngleWinder = 14
</line>
<line>
                ZSingleLanding = 15 /* not supported yet */
</line>
<line>
                ZDoubleLandings = 16/* not supported yet */
</line>
<line>
                DoubleUDoubleLandings = 17 /* O-Stair with two 180 degree landings */
</line>
<line>
                OStairTripleLandings  = 18 /* O-Stair with three 90 degree landings */
</line>
<line>
See SDKLib/Include/Interfaces/Vectorworks/Extension/IStairCWSupport.h for more details.
</line>
</lineList>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 10:54, 8 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns Stair Configuration Type.
ErrorStandardConfiguration = -1, /* Returned by VCOM functions if some error occurs */
StraightStair = 1 /* Numbers need to match strings in string files and need to be consistent for compatibility so do not change order and values of these constants */
StraightTwoRuns = 2
LSingleLanding = 3
USingleLanding = 4
UDoubleLandings = 5
LWinder = 6
UDoubleWinder = 7
USingleWinder = 8
CircularStair = 9
Unused1 /* Required for compatibility */
StraightThreeRuns = 11
LFixedAngleWinder = 12
UDoubleFixedAngleWinder = 13
USingleFixedAngleWinder = 14
ZSingleLanding = 15 /* not supported yet */
ZDoubleLandings = 16/* not supported yet */
DoubleUDoubleLandings = 17 /* O-Stair with two 180 degree landings */
OStairTripleLandings = 18 /* O-Stair with three 90 degree landings */
See SDKLib/Include/Interfaces/Vectorworks/Extension/IStairCWSupport.h for more details.
FUNCTION StairGetConfigType(
stair :HANDLE) : INTEGER;
def vs.StairGetConfigType(stair):
    return INTEGER

Parameters

stair HANDLE

Version

Availability: from Vectorworks 2021