VS:StairGet2D3DCompType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
(3 intermediate revisions by 2 users not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns 2D3D components type of stair.</desc>
<lineList ident=2>
<line>
Returns 2D3D components type of stair.
</line>
<line>
1: 2D
</line>
<line>
2: Hybrid
</line>
<line>
-1: Error
</line>
<line>
See SDKLib/Include/Interfaces/Vectorworks/Extension/IStairCWSupport.h for more details.
</line>
</lineList>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 41: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from Vectorworks 2021
Availability: from Vectorworks 2021 SP3


</version>
</version>
Line 48: Line 65:


[[Category:VS Function Reference|StairGet2D3DCompType]]
[[Category:VS Function Reference|StairGet2D3DCompType]]
[[Category:VS Function Reference:StairCWVectorscripts|StairGet2D3DCompType]]
[[Category:VS Function Reference:Objects - Architectural|StairGet2D3DCompType]]

Latest revision as of 10:43, 8 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns 2D3D components type of stair.
1: 2D
2: Hybrid
-1: Error
See SDKLib/Include/Interfaces/Vectorworks/Extension/IStairCWSupport.h for more details.
FUNCTION StairGet2D3DCompType(
stair :HANDLE) : INTEGER;
def vs.StairGet2D3DCompType(stair):
    return INTEGER

Parameters

stair HANDLE

Version

Availability: from Vectorworks 2021 SP3