VS:SprdFormat

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure SprdFormat determines the number format for cells within the active worksheet.

Values for ldr and trailr may not exceed 8 characters.

Table - Worksheet Cell Formats
Cell Format Constant
General 0
Decimal 1
Decimal/comma 2
Scientific 3
Fractional 4
Dimension 5
Angle 6
PROCEDURE SprdFormat(
numForm :INTEGER;
acc :INTEGER;
ldr :STRING;
trailr :STRING);
def vs.SprdFormat(numForm, acc, ldr, trailr):
    return None

Parameters

numForm INTEGER Numeric format of cell.
acc INTEGER Numeric accuracy setting.
ldr STRING String prefix for cell.
trailr STRING String suffix for cell.

Example

VectorScript

SprdFormat(2, 2, '$', '');
LoadCell(1, 1, '=500 * 3.25');

Python


Version

SprdFormat is obsolete as of VectorWorks 9.0, see new SetWSCellNumberFormat.

Availability: from All Versions

See Also

SetWSCellNumberFormat

[[VS:SetWSCellNumberFormat| SetWSCellNumberFormat]]