VS:SortArray

From Vectorworks Developer
Revision as of 14:39, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sorts a 1-dimension array into ascending order. If the array contains handles to records, the array can be sorted by the specified field number index. If the array is an array of structures, the fieldnumber argument denotes the element in the structure on which to sort.

PROCEDURE SortArray(
VAR arraytosort :ARRAY;
numtosort :INTEGER;
fieldnumber :INTEGER);
def vs.SortArray(numtosort, fieldnumber):
    return arraytosort

Parameters

arraytosort ARRAY
numtosort INTEGER
fieldnumber INTEGER

Remarks

[richn 1/21/00]

Sorts first numtosort elements of single-dimensional array arraytosort into ascending order. If arraytosort is an array of records, it sorts on the fieldnumberth field of the record.

Version

Availability: from VectorWorks9.0