VS:Smooth

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure Smooth sets the smoothing type of newly created polyline or polygon objects.

Table - Smoothing Types
Smooth Type Constant
None 0
Bezier 1
Cubic 2
Arc 3
PROCEDURE Smooth(
smoothType :INTEGER);
def vs.Smooth(smoothType):
    return None

Parameters

smoothType INTEGER Smoothing style.

Example

VectorScript

Smooth(2);
Poly(0, 0, -0.5, 1, 0.5, 2);

Python


Version

Availability: from All Versions