VS:SlabFromPoly: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(no LNewObj support)
(expand)
Line 35: Line 35:
<code lang="pas">
<code lang="pas">
SlabFromPoly(FSActLayer);
SlabFromPoly(FSActLayer);
Locus(0, 0);
Locus(0, 0); { do something to have a marker }
slabHandle := PrevObj(LNewObj); { can't use LNewObj here }
slabHandle := PrevObj(LNewObj); { can't use LNewObj directly to fetch slab }
</code>
</code>
</remark>
</remark>

Revision as of 10:17, 27 January 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a slab object from the referenced polyline. The current settings for the slab object are used to create the new slab.

PROCEDURE SlabFromPoly(
poly :HANDLE);
def vs.SlabFromPoly(poly):
    return None

Parameters

poly HANDLE The polyline that the slab will be created from.

Remarks

(Orso, 2017.01.27): This is one of those objects that don't respond to VS:LNewObj. It also doesn't return any value on VS:GetBBox.

SlabFromPoly(FSActLayer);
Locus(0, 0); { do something to have a marker }
slabHandle := PrevObj(LNewObj); { can't use LNewObj directly to fetch slab }

Version

Availability: from Vectorworks 2011