VS:ShowGradientEditorDialog

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Displays the gradient editor dialog for the specified gradient.

To create and edit a new gradient resource, pass in a handle variable initialized to nil. If successful, the handle variable will be initialized with the handle to the new gradient resource.

PROCEDURE ShowGradientEditorDialog(
VAR gradient :HANDLE);
def vs.ShowGradientEditorDialog(gradient):
    return gradient

Parameters

gradient HANDLE The gradient resource to display in the editor dialog; nil if a new gradient is to be created.

Example

VectorScript

ShowGradientEditorDialog(gradientHandle);
{ displays the specified gradient resource in the editor }

newGradientHandle := nil;
ShowGradientEditorDialog(newGradientHandle);
{ creates a new gradient resource and displays it in the editor }

Python


Version

Availability: from VectorWorks10.0