VS:SetWorkingPlaneN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(Add remark from Raymond Mullin)
Line 40: Line 40:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>([[User:CBM-c-|_c_]] 2022.05.12): From Raymond Mullin, as of VW 2022 any working plane set with this routine doesn't persist after script's end.
 
In VW2012 this command seems not to do anything at all.
In VW2012 this command seems not to do anything at all.
</remark>
</remark>

Revision as of 03:37, 12 May 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set the active working plane.

PROCEDURE SetWorkingPlaneN(
VAR CenterPt_x :REAL;
VAR CenterPt_y :REAL;
VAR CenterPt_z :REAL;
VAR Normal_x :REAL;
VAR Normal_y :REAL;
VAR Normal_z :REAL;
VAR UVec_x :REAL;
VAR UVec_y :REAL;
VAR UVec_z :REAL);
def vs.SetWorkingPlaneN(centerPt, normal, uVec):
    return None

Parameters

centerPt REAL Location of the working plane.
normal REAL Normal vector of the working plane.
uVec REAL The U Vector of the plane.

Remarks

(_c_ 2022.05.12): From Raymond Mullin, as of VW 2022 any working plane set with this routine doesn't persist after script's end.

In VW2012 this command seems not to do anything at all.

Version

Availability: from Vectorworks 2011