VS:SetWallStyle

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Applies the given Wall Style to the given wall, aligning to the given offsets.

FUNCTION SetWallStyle(
theWall :HANDLE;
wallStyle :STRING;
selectedOffDistance :REAL;
replacingOffDistance :REAL) : BOOLEAN;
def vs.SetWallStyle(theWall, wallStyle, selectedOffDistance, replacingOffDistance):
    return BOOLEAN

Parameters

theWall HANDLE The wall.
wallStyle STRING The Wall Style to apply.
selectedOffDistance REAL The offset of the wall to align to.
replacingOffDistance REAL The offset of the Wall Style to align to.

Return Value

Returns success status.

Example

Example

PROCEDURE Example;
VAR
theWall :HANDLE;
wallStyle :STRING;
selectedOffDistance :REAL;
replacingOffDistance :REAL;
BEGIN
theWall := FSActLayer;
wallStyle := 'Ext-2x4-Brick veneer';
selectedOffDistance := 0;
replacingOffDistance := 0;
Message(SetWallStyle(theWall, wallStyle, selectedOffDistance, replacingOffDistance));
END;
RUN(Example);

Python


Version

Availability: from VectorWorks12.5

See Also

VS Functions:

VS:GetWallStyle

VS Functions: [[VS:GetWallStyle]]