VS:SetWallOverallHeights/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(One intermediate revision by the same user not shown)
Line 1: Line 1:
 
{{LocationMain|category=LocationVS/ja|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 29: Line 29:
botBoundType
botBoundType
INTEGER
INTEGER
タイプ(下)[[BR]]0 - レイヤ高さ Z; 1 - デフォルトの壁の高さ; 2 - 高さ基準
タイプ(下)<BR>0 - レイヤ高さ Z; 1 - デフォルトの壁の高さ; 2 - 高さ基準
</line>
</line>
<line>
<line>
botBoundStory
botBoundStory
INTEGER
INTEGER
高さ基準(下)[[BR]]0 - 図形の高さ基準; 1 -  上のストーリ; 2 - 下のストーリ
高さ基準(下)<BR>0 - 図形の高さ基準; 1 -  上のストーリ; 2 - 下のストーリ
</line>
</line>
<line>
<line>
Line 49: Line 49:
topBoundType
topBoundType
INTEGER
INTEGER
タイプ(上)[[BR]]0 - レイヤ高さ Z; 1 - デフォルトの壁の高さ; 2 - 高さ基準
タイプ(上)<BR>0 - レイヤ高さ Z; 1 - デフォルトの壁の高さ; 2 - 高さ基準
</line>
</line>
<line>
<line>
topBoundStory
topBoundStory
INTEGER
INTEGER
高さ基準(上)[[BR]]0 - 図形の高さ基準; 1 -  上のストーリ; 2 - 下のストーリ
高さ基準(上)<BR>0 - 図形の高さ基準; 1 -  上のストーリ; 2 - 下のストーリ
</line>
</line>
<line>
<line>

Latest revision as of 09:56, 16 January 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

壁または円弧壁の全高を設定します。

FUNCTION SetWallOverallHeights(
theWall :HANDLE;
botBoundType :INTEGER;
botBoundStory :INTEGER;
botLayerLevelType :STRING;
botOffset :REAL)Coordinate); topBoundType:INTEGER; topBoundStory:INTEGER; topLayerLevelType:STRING; topOffset:REAL (Coordinate)) : BOOLEAN;
def vs.SetWallOverallHeights(theWall, botBoundType, botBoundStory, botLayerLevelType, botOffset, topBoundType, topBoundStory, topLayerLevelType, topOffset):
    return BOOLEAN

Parameters

theWall HANDLE 壁または円弧壁のハンドル
botBoundType INTEGER タイプ(下)
0 - レイヤ高さ Z; 1 - デフォルトの壁の高さ; 2 - 高さ基準
botBoundStory INTEGER 高さ基準(下)
0 - 図形の高さ基準; 1 - 上のストーリ; 2 - 下のストーリ
botLayerLevelType STRING レイヤのレベルタイプ(下)
botOffset REAL (Coordinate) オフセット(下)
topBoundType INTEGER タイプ(上)
0 - レイヤ高さ Z; 1 - デフォルトの壁の高さ; 2 - 高さ基準
topBoundStory INTEGER 高さ基準(上)
0 - 図形の高さ基準; 1 - 上のストーリ; 2 - 下のストーリ
topLayerLevelType STRING レイヤのレベルタイプ(上)
topOffset REAL (Coordinate) オフセット(上)

Return Value

設定が正しくされたかどうか返します。

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetWallOverallHeights

VS Functions: [[VS:GetWallOverallHeights]]