VS:SetWallHeights: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 14:38, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012. See architectural category for replacement:

DelObjStoryBound
DelObjStoryBounds
GetObjBoundElevation
GetObjStoryBound
GetObjStoryBoundsAt
GetObjStoryBoundsCnt
GetStoryLayerInfo
HasObjStoryBound
HasObjStoryBounds
SetObjectStoryBound

Sets the wall heights of an unstyled wall. Will return false for a styled wall.

FUNCTION SetWallHeights(
h :HANDLE;
startHtDistance :REAL;
endHtDistance :REAL) : BOOLEAN;
def vs.SetWallHeights(h, startHtDistance, endHtDistance):
    return BOOLEAN

Parameters

h HANDLE
startHtDistance REAL
endHtDistance REAL

Example

VectorScript

PROCEDURE Example;
VAR
h :HANDLE;
boo :BOOLEAN;
BEGIN
CallTool(-208);
h := FSActLayer;
boo := SetWallHeights(h, 12, 23);
END;
RUN(Example);

Python


Version

Availability: from VectorWorks12.0

Deprecated: Vectorworks 2012