VS:SetWSSelection

From Vectorworks Developer
Revision as of 22:21, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the current selection range of the referenced worksheet.

In addition to setting the selection range of a worksheet, SetWSSelection will can also set the selection range of database subrows, where applicable.

PROCEDURE SetWSSelection(
worksheet :HANDLE;
currentCellRow :INTEGER;
currentCellColumn :INTEGER;
topRangeRow :INTEGER;
leftRangeColumn :INTEGER;
topRangeSubrow :INTEGER;
bottomRangeRow :INTEGER;
rightRangeColumn :INTEGER;
bottomRangeSubrow :INTEGER);
def vs.SetWSSelection(worksheet, currentCellRow, currentCellColumn, topRangeRow, leftRangeColumn, topRangeSubrow, bottomRangeRow, rightRangeColumn, bottomRangeSubrow):
    return None

Parameters

worksheet HANDLE Handle to worksheet.
currentCellRow INTEGER Row of currently active cell.
currentCellColumn INTEGER Column of currently active cell.
topRangeRow INTEGER Top row of selection range.
leftRangeColumn INTEGER Leftmost column of selection range.
topRangeSubrow INTEGER Top row of of subrow selection range.
bottomRangeRow INTEGER Bottom row of selection range.
rightRangeColumn INTEGER Rightmost column of selection range.
bottomRangeSubrow INTEGER Bottom row of subrow selection range.

Version

Availability: from VectorWorks9.0