VS:SetWSCellLeftBorder

From Vectorworks Developer
Revision as of 22:21, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets a left border with the specified attributes in specified worksheet cells.

SetWSCellLeftBorder allows borders to be set for a rectangular range of cells. To set the border formatting of a single cell, specify identical values for the top/bottom and left/right range boundaries.

Note: A rectangular range of cells is formatted as a single block of cells. If you apply a left border to the range of cells, the border is displayed only on the right edge of the cells.

PROCEDURE SetWSCellLeftBorder(
worksheet :HANDLE;
topRow :INTEGER;
leftColumn :INTEGER;
bottomRow :INTEGER;
rightColumn :INTEGER;
style :INTEGER;
weight :INTEGER;
color :LONGINT);
def vs.SetWSCellLeftBorder(worksheet, topRow, leftColumn, bottomRow, rightColumn, style, weight, color):
    return None

Parameters

worksheet HANDLE Worksheet on which function is to operate.
topRow INTEGER Top row of range to set.
leftColumn INTEGER Left column of range to set.
bottomRow INTEGER Bottom row of range to set.
rightColumn INTEGER Right column of range to set.
style INTEGER Border line style to be set.(0 = None; 2 = Solid, -1..-32 (dash style index) = Dash)
weight INTEGER Border line weight to be set.(in Mils)
color LONGINT Border line color to be set. (color index: 0..255)

Version

Availability: from VectorWorks12.5