VS:SetWSCellBorders

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the borders of cells in the referenced worksheet

SetWSCellBorders allows borders to be set for a rectangular range of cells. To set the border formatting of a single cell, specify identical values for the top/bottom and left/right range boundaries.

Note: A rectangular range of cells is formatted as a single block of cells. If you apply a right border to the range of cells, the border is displayed only on the right edge of the cells.

The borders will be created with default values ( solid style, black color, standard weight).

PROCEDURE SetWSCellBorders(
worksheet :HANDLE;
topRow :INTEGER;
leftColumn :INTEGER;
bottomRow :INTEGER;
rightColumn :INTEGER;
top :BOOLEAN;
left :BOOLEAN;
bottom :BOOLEAN;
right :BOOLEAN;
OutlineInside :INTEGER);
def vs.SetWSCellBorders(worksheet, topRow, leftColumn, bottomRow, rightColumn, top, left, bottom, right, OutlineInside):
    return None

Parameters

worksheet HANDLE Handle to worksheet
topRow INTEGER Top row of cell range
leftColumn INTEGER Left column of cell range
bottomRow INTEGER Bottom row of cell range
rightColumn INTEGER Right column of cell range
top BOOLEAN Top border ON-OFF status
left BOOLEAN Left border ON-OFF status
bottom BOOLEAN Bottom border ON-OFF status
right BOOLEAN Right border ON-OFF status
OutlineInside INTEGER Outline and Inside borders constant

Remarks

OulineInside defines the outline, inside horizontal and inside vertical borders.

Available Constants
Const outline inside horizontal inside vertical
0 false false false
1 true false false
2 false true false
3 true true false
4 false false true
5 true false true
6 false true true
7 true true true


This replaces SetWSCellBorder which became obsolete as of version 12. (You can see obsolete functions by setting the preference on the home page.)

Example

VectorScript

{ Sets the inside horizontal and vertical borders for the specified rectangular range of cells}
SetWSCellBorders(sheet, 2, 4, 1, 5, FALSE, FALSE, FALSE, FALSE, 6);

{ Sets an outline border for the specified rectangular range of cells}
SetWSCellBorders(sheet,2,4,1,5,FALSE,FALSE,FALSE,FALSE,1);
{or}
SetWSCellBorders(sheet,2,4,1,5,TRUE,TRUE,TRUE,TRUE,0);

Python


Version

Availability: from VectorWorks 12.0

See Also

VS Functions:

VS Functions:
  • [[VS:SetWSCellOutlineBorder]]
  • [[VS:SetWSCellInsideVertBorder]]
  • [[VS:SetWSCellInsideHorizBorder]]
  • [[VS:SetWSCellTopBorder]]
  • [[VS:SetWSCellLeftBorder]]
  • [[VS:SetWSCellBottomBorder]]
  • [[VS:SetWSCellRightBorder]]