VS:SetWSCellBorder

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the borders of a cell in the referenced worksheet.

SetWSCellBorder allows text borders to be set for a rectangular range of cells. To set the border formatting of a single cell, specify identical values for the top/bottom and left/right range boundaries.

PROCEDURE SetWSCellBorder(
worksheet :HANDLE;
topRow :INTEGER;
leftColumn :INTEGER;
bottomRow :INTEGER;
rightColumn :INTEGER;
top :BOOLEAN;
left :BOOLEAN;
bottom :BOOLEAN;
right :BOOLEAN;
outline :BOOLEAN);
def vs.SetWSCellBorder(worksheet, topRow, leftColumn, bottomRow, rightColumn, top, left, bottom, right, outline):
    return None

Parameters

worksheet HANDLE Handle to worksheet.
topRow INTEGER Top row of cell range.
leftColumn INTEGER Leftmost column of cell range.
bottomRow INTEGER Bottom row of cell range.
rightColumn INTEGER Rightmost column of cell range.
top BOOLEAN Top border ON-OFF status.
left BOOLEAN Left border ON-OFF status.
bottom BOOLEAN Bottom border ON-OFF status.
right BOOLEAN Right border ON-OFF status.
outline BOOLEAN All borders ON-OFF status.

Version

SetWSCellBorder is obsolete as of VectorWorks 12.0, see new SetWSCellBorders

Availability: from VectorWorks 9.0

See Also

SetWSCellBorders

[[VS:SetWSCellBorders| SetWSCellBorders]]