VS:SetWSCellAlignment: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
Line 15: Line 15:
! Alignment !! Constant
! Alignment !! Constant
|-  
|-  
| General
| Left
| style="text-align:center"| 1
| style="text-align:center"| 1
|-  
|-  
| Left
| Center
| style="text-align:center"| 2
| style="text-align:center"| 2
|-  
|-  
Line 24: Line 24:
| style="text-align:center"| 3
| style="text-align:center"| 3
|-  
|-  
| Center
| General
| style="text-align:center"| 4
| style="text-align:center"| 4
|}
|}

Latest revision as of 09:48, 19 March 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the horizontal alignment of a cell in the referenced worksheet.

SetWSCellAlignment allows a formula to be inserted into a rectangular range of cells. To set the alignment of a single cell, specify identical values for the top/bottom and left/right range boundaries.

Alignment index values for worksheet cells correspond to the horizontal alignment index values for text used by VectorScript.

Table - Worksheet Cell Alignment
Alignment Constant
Left 1
Center 2
Right 3
General 4
PROCEDURE SetWSCellAlignment(
worksheet :HANDLE;
topRow :INTEGER;
leftColumn :INTEGER;
bottomRow :INTEGER;
rightColumn :INTEGER;
cellAlignment :INTEGER);
def vs.SetWSCellAlignment(worksheet, topRow, leftColumn, bottomRow, rightColumn, cellAlignment):
    return None

Parameters

worksheet HANDLE Handle to worksheet.
topRow INTEGER Top row of cell range.
leftColumn INTEGER Leftmost column of cell range.
bottomRow INTEGER Bottom row of cell range.
rightColumn INTEGER Rightmost column of cell range.
cellAlignment INTEGER The new alignment index value.

Version

Availability: from VectorWorks 9.0