VS:SetView/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:38, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

視点を、指定した3次元軸を中心に、指定した角度で回転させます。

PROCEDURE SetView(
xAngle :REAL;
yAngle :REAL;
zAngle :REAL;
xDistance :REAL)Coordinate); yDistance:REAL (Coordinate); zDistance:REAL (Coordinate));
def vs.SetView(xAngle, yAngle, zAngle, xDistance, yDistance, zDistance):
    return None

Parameters

xAngle REAL X座標の角度
yAngle REAL Y座標の角度
zAngle REAL Z座標の角度
xDistance REAL (Coordinate) 視点の中心のX座標
yDistance REAL (Coordinate) 視点の中心のY座標
zDistance REAL (Coordinate) 視点の中心のZ座標

Example

SetView(45d,30d,30d,0,2,2);

Version

利用可能バージョン: MiniCAD