VS:SetVSResourceFile

From Vectorworks Developer
Revision as of 14:38, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the active resource file for a script. The resource file is opened for the duration of script execution.

The name of the resource file should be specified without the file extension.

FUNCTION SetVSResourceFile(
fileName :STRING) : BOOLEAN;
def vs.SetVSResourceFile(fileName):
    return BOOLEAN

Parameters

fileName STRING The name of the resource file to be opened.

Return Value

A BOOLEAN value indicating the success of the file open operation.

Remarks

Specify the file name without an extension. However, the file must exist in the plug-ins folder WITH an extension. Use .rsr on Windows and .rsrc on the Mac.

Version

Availability: from VectorWorks9.0

See Also

VS Functions:

VS:GetResourceString

VS Functions: [[VS:GetResourceString]]