VS:SetVSResourceFile: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
No edit summary
 
(One intermediate revision by the same user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
<b>This function does not do anything in Vectorworks 2015 and later.</b> This is because the resource system changed. See more at: [[Vectorworks VWR Resources]]
As of Vectorworks 2015, resources are accessed directly by specifying full resource path (resource identifier) and using [[VS:GetVWRString]]
Pre Vectorworks 2015:
Sets the active resource file for a script. The resource file is opened for the duration of script execution.
Sets the active resource file for a script. The resource file is opened for the duration of script execution.



Latest revision as of 12:51, 23 September 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function does not do anything in Vectorworks 2015 and later. This is because the resource system changed. See more at: Vectorworks VWR Resources

As of Vectorworks 2015, resources are accessed directly by specifying full resource path (resource identifier) and using VS:GetVWRString

Pre Vectorworks 2015: Sets the active resource file for a script. The resource file is opened for the duration of script execution.

The name of the resource file should be specified without the file extension.

FUNCTION SetVSResourceFile(
fileName :STRING) : BOOLEAN;
def vs.SetVSResourceFile(fileName):
    return BOOLEAN

Parameters

fileName STRING The name of the resource file to be opened.

Return Value

A BOOLEAN value indicating the success of the file open operation.

Remarks

Specify the file name without an extension. However, the file must exist in the plug-ins folder WITH an extension. Use .rsr on Windows and .rsrc on the Mac.

Version

Availability: from VectorWorks9.0

See Also

VS Functions:

VS:GetResourceString

VS Functions: [[VS:GetResourceString]]